概要
このエディタの主な目的は、GO2camによって生成されたISOプログラムを表示することです。 GO2cam .
そのため、ISOに特化した比較、モーション検索、ISOハイライトなどの新機能が含まれています。
エディタで利用可能なすべてのショートカットと組み合わせも、時間を大幅に節約するために役立ちます。以下をお読みください。 エディタショートカット .
メニュー別機能説明
ファイルメニュー
|
新規 |
新規ファイルの作成 |
|
|
開く |
既に作成されたファイルを開くことができます。複数のファイルを同時に開くことも可能です。 |
|
|
保存 |
登録済みのファイルを保存する |
|
|
名前を付けて保存... |
新規ファイルを保存するか、ファイルに新しい名前を付ける |
|
|
比較 & 比較を終了 |
2つのファイルを比較できます。2種類のサイクルで生成されたISOブロック、または2つの異なるポストプロセッサで生成されたISOブロックを比較するのに非常に役立ちます。CNCマシンからプログラムを回復し、元のGO2camプログラムと比較することもできます。 |
|
|
ページレイアウト |
印刷前のページプロファイルのセットアップ |
|
|
印刷 |
現在のファイルを印刷する |
|
|
最近のファイル |
最後に開いたファイルを開くことができます。 |
|
|
終了 |
エディタを閉じる |
編集メニュー
|
取り消し |
アクションを取り消すことができます。複数回実行可能です。 |
|
|
やり直し |
'取り消し'アクションでキャンセルされたものを呼び戻すことができます。 |
|
|
切り取り / コピー / 貼り付け |
選択した行を切り取りまたはコピーし、ファイル内の別の場所または別のファイルに貼り付けることができます。 |
|
|
削除 |
選択した行を削除する |
|
|
特殊削除 |
選択したカテゴリ(スペース、空行、ブロック番号、コメント)を削除する |
|
|
検索 |
ファイル全体または選択した領域で、あらゆる種類の文字または単語を検索する。 |
|
|
置換 |
あらゆる種類の文字または単語を検索し、ダイアログで入力した文字または単語に置き換える。一度だけ実行するか、テキスト全体に適用するかを選択できます。 |
|
|
行へ移動 |
必要な行に移動するための非常に便利なオプションです。行番号を入力します(「表示」メニューで行番号を表示するかどうかを選択できます)。 |
|
|
すべて選択 |
ファイルの内容全体を選択する |
|
|
ブックマーク |
ブックマークを設定/削除し、ナビゲートする |
表示メニュー
|
行を表示する |
行番号を表示できます。 |
|
|
フォント... |
別のフォントを選択する |
|
|
表示モードを変更する |
|
|
|
構文の色分け |
ファイル全体がハイライトされ、ISOコードをさまざまな色分けで示します。 |
NCツールメニュー
|
短いモーションを見つける |
必要な距離を入力し、この値よりも小さいパスがあるかどうかを確認します。 |
|
|
プログラムの状態 |
各行(工具交換、主軸回転数、送り速度など)に関して、サイクルの詳細を取得できます。 |
エディタの選択
プログラムのNC出力用にエディタソフトウェアを設定することもできます。その方法は次のとおりです。
-
カスタマイズオプションで、エディタ名フィールドにエディタの.exeを選択します。
-
テキストメニューのツールからエディタに移動するか、エディタを選択します。
NCコードは、選択したエディタで開かれます。